Añadir disco compartido a una VM en ODA

Problema:

Necesitamos añadir un nuevo disco a una VM en ODA con la versión:

[root@test-oda ~]# oakcli show version
Version
-------
12.1.2.11.0
[root@test-oda~]#

Solucion:

El proceso es fácil. El esquema general sería en siguiente

  1. Crear disco en repositorio compartido
  2. Añadir disco a la máquina
  3. Comprobar que se ha añadido de manera correcta

Adjuntamos los pasos ejecutados en códio

root@oda-node1 ~]# oakcli create vdisk vm-disk -repo oda-repo -size 10G -type shared

Created Vdisk : oakvdk_zezere-disk

[root@oda-node1 ~]# oakcli modify vm vm-demo -attachvdisk vmdisk

Configured VM : vm-demo. Changes will take effect on next restart of VM.


[root@oda-node1 ~]# oakcli show vm vm-demo
The Resource is : zezere
        AutoStart       :       restore        
        CPUPriority     :       100            
        Disks           :       |file:/OVS/Repositories/vmrepo/.
                                ACFS/snaps/VirtualMachines/z
                                ezere/62e6a5ebba36477d98e369fdb429a
                                4fd.img,xvda,w|
        Domain          :       XEN_PVM        
        DriverDomain    :       True           
        ExpectedState   :       online         
        FailOver        :       false          
        IsSharedRepo    :       true           
        Keyboard        :       en-us          
        MaxMemory       :       40960M         
        MaxVcpu         :       8              
        Memory          :       8192M          
        Mouse           :       OS_DEFAULT     
        Name            :       vm-demo         
        Networks        :       |bridge=net1||bridge=net2|
        NodeNumStart    :       0              
        OS              :       OL_5           
        PrefNodeNum     :       0              
        PrivateIP       :       None           
        ProcessorCap    :       0              
        RepoName        :       odavmrepo      
        State           :       Online         
        TemplateName    :       Template OEL7         
        VDisks          :       |vm-disk
        Vcpu            :       8              
        cpupool         :      AppCpuPool  
        vncport         :       5903           

[root@oda-node1 ~]# oakcli show version
Version
-------
12.1.2.11.0
[root@oda-node1 ~]#

ERROR Invalid username and or password en Enterprise Manager Control 13 al lanzar trabajo sobre máquina windows

Problema:

Queremos lanzar un script desde el Enterprise Manager Control 13, sobre una maquina windows, en nuestro caso windows server 2012 R2.

Al ejecutar el trabajo obtenemos el siguiente error «Host Credentials ERROR Invalid username and or password» Pero el acceso por ssh a la máquina o la monitorización de la base de datos es correcta.

Solución:

Es permitir que el trabajo se pueda ejecutar con los siguientes permisos «Log on as batch job», para ello:

Herramientas administrativas->Política loca de seguridad-> Política local->Permisos de usuario y buscamos la siguiente propiedad «Log on as batch job”; y añadimos el usuario y el grupo que son usadas como credenciales desde el cloud control